<br><br><div class="gmail_quote">On 26 October 2011 15:43, Kevin Ross <span dir="ltr">&lt;<a href="mailto:kevross33@googlemail.com">kevross33@googlemail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
I will just set it to http for the time being for the ET rules :-) Strange though; I am wondering if it was perhaps an update in Fedora or something that made it not happy (I know there was a perl update for security and I did see Crypt::SSLeay was updated too when yum finished. <br>
<div><div></div><div class="h5">
<br><div class="gmail_quote">On 26 October 2011 15:34, JJC <span dir="ltr">&lt;<a href="mailto:cummingsj@gmail.com" target="_blank">cummingsj@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div>you can try changing the url to what Victor said and / or.. though I&#39;m more inclined to go with what Victor said.. well atleast look at the cert and see ;-)</div><br><span style="border-collapse:collapse;font-family:arial, sans-serif;font-size:13px">:SSL3_GET_SERVER_</span><span style="border-collapse:collapse;font-family:arial, sans-serif;font-size:13px">CERTIFICATE:certificate verify failed</span><div>


<font face="arial, sans-serif"><span style="border-collapse:collapse"><br></span></font></div><div><font face="arial, sans-serif"><span style="border-collapse:collapse">from the PP faq:</span></font></div>
<div><font face="arial, sans-serif"><span style="border-collapse:collapse"><span style="font-size:13px;border-collapse:separate"><p style="line-height:1.25em;max-width:64em">
<b>When I run PP, I get a 500 error and something about Certificate Authority or verification about SSL Peers</b></p><ul style="padding-left:25px;max-width:62em"><li style="margin-bottom:0.3em">install or update Mozilla::CA IO::Socket::SSL</li>


<ul style="padding-left:25px;max-width:62em"><li style="margin-bottom:0.3em">Will fix it most times. The Mozilla::CA installs/updates the perl root certificates and IO::Socket::SSL enables ssl verification by hostname in Crypt::SSLeay.</li>


</ul><li style="margin-bottom:0.3em">Update your trusted root certificates on your OS, consult the documentation for your OS to do this.</li><li style="margin-bottom:0.3em">Alternately you can change the url to http from https for your snortrules tarball.</li>


</ul></span></span></font></div><div><div></div><div><div><div class="gmail_quote">On Wed, Oct 26, 2011 at 8:27 AM, Kevin Ross <span dir="ltr">&lt;<a href="mailto:kevross33@googlemail.com" target="_blank">kevross33@googlemail.com</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hmmm actually it is now working on VRT but not ET:<br><br>Checking latest MD5 for emerging.rules.tar.gz....<br>        Fetching md5sum for: emerging.rules.tar.gz.md5<br>** GET <a href="https://rules.emergingthreats.net/open-nogpl/snort-2.9.0/emerging.rules.tar.gz.md5" target="_blank">https://rules.emergingthreats.net/open-nogpl/snort-2.9.0/emerging.rules.tar.gz.md5</a> ==&gt; 500 Can&#39;t connect to <a href="http://rules.emergingthreats.net:443" target="_blank">rules.emergingthreats.net:443</a> (SSL connect attempt failed with unknown errorerror:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)<br>



        Error 500 when fetching <a href="https://rules.emergingthreats.net/open-nogpl/snort-2.9.0/emerging.rules.tar.gz.md5" target="_blank">https://rules.emergingthreats.net/open-nogpl/snort-2.9.0/emerging.rules.tar.gz.md5</a> at /etc/snort/pulledpork/<a href="http://pulledpork.pl" target="_blank">pulledpork.pl</a> line 453<br>



        main::md5file(&#39;open-nogpl&#39;, &#39;emerging.rules.tar.gz&#39;, &#39;/tmp/&#39;, &#39;<a href="https://rules.emergingthreats.net/open-nogpl/snort-2.9.0/" target="_blank">https://rules.emergingthreats.net/open-nogpl/snort-2.9.0/</a>&#39;) called at /etc/snort/pulledpork/<a href="http://pulledpork.pl" target="_blank">pulledpork.pl</a> line 1758<div>


<div></div><div><br>
<br><br><br><br><div class="gmail_quote">On 26 October 2011 15:23, JJC <span dir="ltr">&lt;<a href="mailto:cummingsj@gmail.com" target="_blank">cummingsj@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



Sweet, thanks for letting us know!<div><div></div><div><br><br><div class="gmail_quote">On Wed, Oct 26, 2011 at 8:17 AM, Kevin Ross <span dir="ltr">&lt;<a href="mailto:kevross33@googlemail.com" target="_blank">kevross33@googlemail.com</a>&gt;</span> wrote:<br>




<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Got it, it wanted IO::Socket:SSL though never warned until I used verbose mode. Strange thing is one of the sensors this started happening on was updating happily last week and wasn&#39;t changed (though the others were and stopped working so I thought I was being stupid and missed something out then other one stopped). <br>





<br>Oh well it is working now. Thanks :D<div><div></div><div><br><br><div class="gmail_quote">On 26 October 2011 15:09, JJC <span dir="ltr">&lt;<a href="mailto:cummingsj@gmail.com" target="_blank">cummingsj@gmail.com</a>&gt;</span> wrote:<br>




<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Generally this is attributable to a certificate issue.  I would run in extra verbose mode (-vv) and there should be some more specific errors about the connection issue.<div><br></div><div><font color="#888888">JJC</font><div>





<div></div><div><br><br><div class="gmail_quote">
On Wed, Oct 26, 2011 at 2:58 AM, Kevin Ross <span dir="ltr">&lt;<a href="mailto:kevross33@googlemail.com" target="_blank">kevross33@googlemail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">






Anyone else having similar issues? Strange thing is this was working only the other week. Same thing happens if ET only, if using HTTP etc and it was updating successfully before.<br><br>    <a href="http://code.google.com/p/pulledpork/" target="_blank">http://code.google.com/p/pulledpork/</a><br>







      _____ ____<br>     `----,\    )<br>      `--==\\  /    PulledPork v0.6.1 the Smoking Pig &lt;////~<br>       `--==\\/<br>     .-~~~~-.Y|\\_  Copyright (C) 2009-2011 JJ Cummings<br>  @_/        /  66\_  <a href="mailto:cummingsj@gmail.com" target="_blank">cummingsj@gmail.com</a><br>







    |    \   \   _(&quot;)<br>     \   /-| ||&#39;--&#39;  Rules give me wings!<br>      \_\  \_\\<br> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~<br><br>Checking latest MD5 for snortrules-snapshot-2910.tar.gz....<br>







    Error 500 when fetching <a href="https://www.snort.org/reg-rules/snortrules-snapshot-2910.tar.gz.md5" target="_blank">https://www.snort.org/reg-rules/snortrules-snapshot-2910.tar.gz.md5</a> at /etc/snort/pulledpork/<a href="http://pulledpork.pl" target="_blank">pulledpork.pl</a> line 453<br>







    main::md5file(&#39;d9ac73ada9e6a80d442704b17b127d1c38f41200&#39;, &#39;snortrules-snapshot-2910.tar.gz&#39;, &#39;/tmp/&#39;, &#39;<a href="https://www.snort.org/reg-rules/" target="_blank">https://www.snort.org/reg-rules/</a>&#39;) called at /etc/snort/pulledpork/<a href="http://pulledpork.pl" target="_blank">pulledpork.pl</a> line 1758<br>







<br><br>
</blockquote></div><br></div></div></div>
</blockquote></div><br>
</div></div></blockquote></div><br>
</div></div></blockquote></div><br>
</div></div></blockquote></div><br></div>
</div></div></blockquote></div><br>
</div></div></blockquote></div><br>